Overview
A disconnected Agent is one that cannot connect or communicate with Peer Management Center and Peer Management Broker in a timely fashion.
Causes
Many factors can cause an Agent to disconnect. Causes include:
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The server hosting the Peer Management Center and Peer Management Broker is down.
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The server hosting the Agent is down.
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The Peer Management Broker Service is down.
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The Peer Agent Service is down.
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The connectivity between the Broker and the Agent is still functioning but very slow to respond.
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The timeout setting (Missed Heartbeats before Agent Disconnect) is set too low.
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The IP of the Peer Management server has changed.
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The service account for the Agent has changed or the password has changed.
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New firewall restrictions are restricting communication between the Agent and the Peer Management Broker.
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The Agent is being updated to a new version.
Reconnecting an Agent
The Agent should connect automatically once the cause is resolved.
Related articles
Page: Connectivity issue during Agent update Page: Firewall Requirements Page: How does the Lock function behave when there is a disconnect between Agents and the PMC and broker? Page: HSTS blocks access to the PMC's web interface Page: Throttle bandwidth between the Broker and a remote Agent Page: Using the PortCheck utility to troubleshoot connectivity issues Page: What causes an Agent to disconnect? Page: What do the Agent connection statuses mean? Page: What firewall settings are needed to enable PeerGFS uploads and download software updates? Page: What is a quorum and how did I lose it?