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Error when saving password in PeerSync v9.3.1

Problem

After upgrading to PeerSync v9.3.1, you cannot save a password (using the new encryption logic):

The following error message is displayed:

Cause

This issue is typically caused by old versions of PeerLib DLLs remaining on the system after the upgrade.

Solution

  1. Uninstall all versions of PeerSync and the PSListener.
  2. Go to the Windows\System32 directory and remove all PeerLib_.dll's.
  3. Go to the Windows\SysWOW64 (on 64-bit servers) and remove all PeerLib_.dll's.
  4. Reinstall the latest version of PeerSync.

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