Error when saving password in PeerSync v9.3.1
Problem
After upgrading to PeerSync v9.3.1, you cannot save a password (using the new encryption logic):
The following error message is displayed:
Cause
This issue is typically caused by old versions of PeerLib DLLs remaining on the system after the upgrade.
Solution
- Uninstall all versions of PeerSync and the PSListener.
- Go to the Windows\System32 directory and remove all PeerLib_.dll's.
- Go to the Windows\SysWOW64 (on 64-bit servers) and remove all PeerLib_.dll's.
- Reinstall the latest version of PeerSync.
Related articles
- Can I use DFS Namespaces when specifying folder paths in PeerSync?
- Configure PeerSync Listener's advanced settings
- Configure the PeerSync Listener installer to run unattended
- Does PeerSync Listener have to be installed on both servers when using the ByteReplicator?
- How does the ByteReplicator work?
- Set up synchronization/replication over TCP
- Uninstaller not working on Windows 2012 or Newer
- Upgrade PeerSync and PeerSync Listener
- Why does ByteReplicator use .BRTMP temporary files?