Cannot upgrade PeerIQ virtual appliance via the console menu
Problem
When attempting to upgrade software via the console menu on a PeerIQ virtual appliance, the following error message is displayed:
Cause
Microsoft recently discontinued the service that we used to make our product installers available via a content delivery network. The replacement service lacks some of the previous capabilities, which prevents our upgrade logic from working within the virtual appliances' console menu system.
Solution
To resolve this issue, a new version of the console menu system is available. Upgrading to this version requires the following manual steps:
Connect into the virtual appliance via SSH.
Download the new
menu.sh
file using the command:CODEwget https://peerdownloads.blob.core.windows.net/appliances/61/menu_linux_6_1_0_64_piq.sh
Make the new script executable:
CODEchmod a+x menu_linux_6_1_0_64_piq.sh
Launch the new script:
CODEsudo ./menu_linux_6_1_0_64_piq.sh
Select Upgrade this Menu.
Select Download and press Enter.
When the update is complete, select OK.
Select Exit.
After completing these steps, you can re-run the script that launches the console menu system and proceed with the desired upgrades using the command:
sudo menu.sh
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- Update Peer Global File Service (PeerGFS)
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